I suggest you ...

many papers from one author the same year

Here's the problem i'm facing. One author wrote many paper the same year. if i want to cite them all, it's impossible to kow which one i cited. ex.: YAIR (2000, 2000) should be YAIR (2000a, 2000b)!

118 votes
Vote
Sign in
Signed in as (Sign out)
You have left! (?) (thinking…)
drpatgirdrpatgir shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
completed  ·  Robert KnightRobert Knight responded  · 

Disambiguation of citations, using the rules specified by the current style was implemented in the 0.9.8 release last autumn.

24 comments

Sign in
Signed in as (Sign out)
Submitting...
  • Athena LemesiouAthena Lemesiou commented  ·   ·  Flag as inappropriate

    Hi, see my post just below yours. You need to choose "Harvard - Staffordshire University". It was the only one that took care of that problem for me.

  • AnonymousAnonymous commented  ·   ·  Flag as inappropriate

    I am using Mendeley 1.5.1 with Harvard Style 1 and I am having the same problem.

    In fact now don't know which is paper a, b, c etc from the authors with multiple papers in the same year, as it has deleted the indicator in the database.

    My thesis is due in 2 weeks and I have a big problem, please help me find a fix.

  • Athena LemesiouAthena Lemesiou commented  ·   ·  Flag as inappropriate

    just to say that the citation style that effectively takes care of this issue is "Harvard - Staffordshire University". All the other listed Harvard styles do not use lowercase letters (a,b,c etc) to cite publications from the same author in the same year... Instead, they continue listing all the other authors in the order they are found on the paper and stop when they reach one that differs. For example an article by "K, L, M, N, Q (2000)" and "K, L, M, O, R (2000)" is referenced as "K, L, M, N et al 2000" and "K, L, M, O et al 2000" respectively by ALL listed Harvard styles, except from Harvard - Staffordshire University which will give you "K et al (2000a)" and "K et al (2000b)" which is what you need.

  • Athena LemesiouAthena Lemesiou commented  ·   ·  Flag as inappropriate

    Hi, I am new to Mendeley and I have just come across this as well. In my case it automatically adds the 2nd (and 3rd author if the 2nd one is also the same) and then et al and the date to differentiate between the two articles. Is there no way of just adding the lowercase letter next to the year instead of ending up with very long in-text citations?

  • Richy CRichy C commented  ·   ·  Flag as inappropriate

    I still have the problem with version 1.0.1. Anyone know a workaround until this gets fixed? I can't see a way to manually edit or clear the citation key. Thanks!

  • Anonymous commented  ·   ·  Flag as inappropriate

    mendeley 1.0 does NOT generate unique keys - I have several similar ones with author/year. when I remove a key manually it is regenerated, but still with the value that is not unique.

  • @orgmotivation@orgmotivation commented  ·   ·  Flag as inappropriate

    Any news on whether this will be fixed? I have just switched to Mendeley but thinking of going back to zotero because this will cause me big problems.

  • abiabi commented  ·   ·  Flag as inappropriate

    Yes, please fix this. I agree with osm and dbruce.atkinson that this feature is crucial and should be given preference.

  • MMMM commented  ·   ·  Flag as inappropriate

    For word 2007 this function is not fully working. For the first citation it will always come up as (author year), whilst when you insert a second citation for the same author and year it will show as (author year b) and when you then use the same source as the first it will show as (author year a), but the very first citation will never be changed to a.

  • billjoiebilljoie commented  ·   ·  Flag as inappropriate

    In OpenOffice 3.2, this issue is fixed by the 9.8 update. Fully functional, no problem.

  • JborgerJborger commented  ·   ·  Flag as inappropriate

    This is also related to the file naming and Bibtex key generation issues. A common bibtex key is \cite{FirstAuthorYear} with an a, b, c etc behind the year for papers from the same first author and year. I currently use this schema for my labels in Endnote AND for my keys in BibTeX AND for the pdf file names in my library (the only way to be sure I'll have some sort of organised scheme which is sort-of portable between word and LaTeX). While I understand that Mendeley is relatively new and that it has a lot of promise in making other aspects of referencing and citing much easier, it would be be nice if this sort of consistency was possible here too. There should be a means to automatically generate keys in this way and also to name files in this (or similar) way. Currently Mendeley uses a number of Authors in the file names making a reference library into an unholy mess.

    So some sort of consistent coherent and concise strategy with file names and keys still needs to be sorted out. Then it will truly be a system which will be useful in word, open office AND LaTeX.

  • Omar MianOmar Mian commented  ·   ·  Flag as inappropriate

    This is a real nuisance. Please fix this critical issue before spending time on all the fancy stuff.

  • billjoiebilljoie commented  ·   ·  Flag as inappropriate

    Response to mdediana: Either I do not understand you trick, or this does not solve the problem. As far as I understood, citation keys had more to do with inserting citations in LaTex documents, not on the formatting of the in-line citation. Can it have any incidence on the final output of the document? Plus, citation keys don't change anything for OpenOffice or MS Word users, as far as I understand. Did I miss something?

  • mdedianamdediana commented  ·   ·  Flag as inappropriate

    A workaround to this issue: go to Document Details (it's the 2nd tab under Tools -> Options) choose the document type you want to edit and check 'Citation Key'. By doing that, it's possible to choose the key to use for the document. An annoying procedure, but at least things are working here now.

  • billjoiebilljoie commented  ·   ·  Flag as inappropriate

    Well, there seems to have been a partial fix since I last looked into this, but in a way it seems to make things worse. If I insert 2 citations by Smith 1840, I get Smith (1840a) and Smith (1840b) in the in text citation. However, these do not show up in the bibliography! Worse yet, the suffixes follow the order in which the citations are inserted, not the order in which the papers appear in the bibliography. So reading my paper, someone might be misled into thinking that Smith(1840a) is the first reference by this author in the bibliography, while it is actually the second (due to alphabetical ordering of the titles. This is a major problem. The Mendeley team should forget all the fancy improvements and start by getting the citations right.

  • asuasu commented  ·   ·  Flag as inappropriate

    I'm also encountering this problem, and relieved to know that it wasnt only me who had this problem... I hope this bug would be fixed asap since it's a pain to fix all citation manually...

  • Milan KarowMilan Karow commented  ·   ·  Flag as inappropriate

    Mendeley ignores CSL's "disambiguate-add-year-suffix" option within citations (and within the bibliography). This is a critical bug and should be fixed immediately. In our "publish-or-perish" scientific community, multiple papers per year from one author are not uncommon.

    Until this bug is fixed, Medeley is virtually useless as citation plugin. Zotero implements this correctly.

← Previous 1

Feedback and Knowledge Base